Script

FTP

The professional tool to automate FTP, SFTP, FTPS

and schedule FTP batch jobs

MENU MENU
Post here if you experience file transfer problems or unexpected errors.
Dear community,

I hope someone here can help us.

We are currently experiencing a very strange behavior in connection with ScriptFTP using the Windows Task Scheduler.

We are using ScriptFTP version 4.5.0.0 on a Windows Server 2012 (build 9200).

All our scripts work fine under the following circumstances:
- Manually started by double-clicking a batch file that calls ScriptFTP-Console in combination with the corresponding script
- Manually triggered by right-clicking the associated task in the task scheduler and choosing “Run”
- Timed call via task scheduler while logged in to the server

Our problem is: the timed call via Windows Task Scheduler of some scripts does NOT work if you are not logged in to the server, although Windows Task Scheduler reports everything is fine.

Since we are logging the output of the batch file, we can see
a) that it IS triggered the way we set it up and
b) that in the corresponding log file that ScriptFTP reports as follows:
„úúúúúú ScriptFTP internal error
úúúúúú Unable to compile intermediate script file. Please, send your script file to support@scriptftp.com“

In order to rule out possible errors in our script (which would be illogical, because triggered manually it worked great, but we wanted to consider all eventualities), we even have created a test script which only contains a local directory change (via LOCALCHDIR). However, exactly the same error occurs as described above.
The craziest thing is that several FTP jobs are already triggered in exact the same way (user, task-configuration etc.) on this server and these work perfectly.

Do you have any idea what might be causing the problem?

Thanks in advance,
Oliver Bleckmann
Hello Oliver,

Thanks for all the details. It is bit strange, the message "Unable to compile intermediate script file" happens when the script syntax is correct but for some reason the internal compilation that ScriptFTP performs failed... Well, that does not help at all, I know. But just to give you some context.

In order to fix this I would need to see the error happening in your computer. Would you mind to book a time for a quick call? We will use the phone and Zoom screen sharing (or any other tool you prefer)

https://calendly.com/frozenfrog-software/phone-or-online-meeting


I think this is the only way as getting the same error here is not possible. Scheduling always works as expected, at least here.