Script

FTP

The professional tool to automate FTP, SFTP, FTPS

and schedule FTP batch jobs

MENU MENU
Post here if you experience file transfer problems or unexpected errors.
I run my script and it connects but does not download anything. I don't get any error messages so I have no idea what to check. I've made sure the files are there. I even see the temp file being created and removed on the server where the files are located. I've tried putting other files there in case the current files are an issue, but still nothing happens.

The files have file extensions and I can manually download and upload files to the server with another FTP client.

The server that I am connecting to is Windows 2012.

Any ideas?
Running C:\Users\Administrator\Documents\UK_LMS_DB2.ftp

OPENHOST("164.40.155.147","administrator",******)
Connecting to 164.40.155.147
Connected.

SETPASSIVE(DISABLED)
Disabling passive mode.

SYNC("c:\db_archives\new","/db_backups",DOWNLOAD,SUBDIRS,"*.*")
Uploading temporary file to calculate server-client clock time difference.
Clock time difference is 21570 seconds.
Synchronizing local directory c:\db_archives\new from /db_backups.

CLOSEHOST
Disconnected.
I was able to solve this issue.

After further research, the "LIST" command was not working on the server. For some reason, on Windows 2012 Server, make sure you set your IIS FTP server "FTP Directory Browsing/Directory Listing Style" to UNIX.

It was very strange since only the ScriptFTP client was the only FTP client that was affected by this. Filezilla was using LIST and it would work fine.

Not sure the reason behind this, but at least it is working.
Thanks for reporting this. Microsoft FTP server reports DOS-formatted file listings and ScriptFTP sometimes do not know how to read them. We are working to fix this.
The program all of a sudden today would not read the default Microsoft ftp directory browsing “MSDOS” changed to “UNIX” directory browsing….. working again. Sheesh.