Script

FTP

The professional tool to automate FTP, SFTP, FTPS

and schedule FTP batch jobs

MENU MENU
Post here if you experience file transfer problems or unexpected errors.
I have a script that is working just about perfectly.

I have a file name that has an apostrophe in it. The ADDEXCLUSION command does not function with an apostrophe in the file name.

Example:
FTP Script
  1. ADDEXCLUSION (REMOTE,  "John O'Connor/")
This folder is not excluded - Anyone have a solution?

Thanks for any assistance.
Hi,

I have just tested ADDEXCLUSION with apostrophes and it works. See the screenshot below.

Note that there are different types of apostrophes: ` ´ ' . They are different characters. I would check that.

My test script:
FTP Script
  1. OPENHOST("127.0.0.1","test","1234")
  2. ADDEXCLUSION (REMOTE, "John O'Connor/")
  3. GETFILE("*.*",SUBDIRS)
Attachments
excluding_a_remote_folder.jpg
excluding_a_remote_folder.jpg (98.48 KiB) Viewed 957 times
Thank you. By copying your ' and pasting it into my script, it indeed did exclude the directory.

Now, I have one other folder that has a small DOT or bullet in the line between words. It is not a period, but a symbol.

I tried to add" joe%EF%80%A2 the guy"to create the symbol, but that didnt work.
I tried to add" joe%EF%80%A2 the guy"to create the symbol, but that didnt work.
:)
This is some kind of URL enconding of the characters. ScriptFTP does not support that. You have to enter the character directly in the script file (as your were actually typing it) but beware that in order to the non-english or not-so-common characters to be supported by ScriptFTP you have to save the .ftp as an UTF8 text file.

This is enabled by default but, just in case, in the Notepad or the editor you use for the script file, under the Save as... window. Check that the encoding is actually UTF8.
Attachments
utf8.jpg
utf8.jpg (86.05 KiB) Viewed 951 times
I used the ' that you posted in your example and it worked. I am also finding that a period . in a folder name (Joe.jones) is also causing issues in the exclusion list not recognizing it.

I use a regular MAC keyboard so I can't figure out how one ' can be different from another. Same question applies to periods .